Wireless Internet at Hutchison Career Center is reported to be down. We are investigating.
Incident Report for OIT Services
Resolved
We are working with UAF CTC to restore WiFi to Hutchinson Career Center. Please contact OIT if you have questions.
Posted Apr 16, 2018 - 17:43 AKDT
Investigating
As of 4PM Wireless Internet at UAF Campus, Hutchison Career Center is reported to be down. We are investigating.
Posted Apr 16, 2018 - 16:14 AKDT