Pharos Printing Outage
Incident Report for OIT Services
Resolved
We are pleased to report that Pharos printing is available again. If you are still having difficulty please reach out to us for assistance! http://alaska.edu/oit/get-help/
Posted Aug 15, 2018 - 16:30 AKDT
Investigating
We are currently investigating an outage of Pharos Printing. We are still trying to figure out a cause of this outage. Sorry for the inconveniences this may be causing.
Posted Aug 15, 2018 - 16:09 AKDT