DocuSign Outage

Incident Report for OIT Services

Resolved

DocuSign reports that this incident has been resolved. They add that if you are still experiencing issues, you may need to log out and back into the application.

Thank you for your time while this issue was resolved!
Posted Jul 18, 2025 - 13:03 AKDT

Monitoring

DocuSign reports that they have implemented a fix and are monitoring the results. https://apps.docusign.com/send/ should now be accessible for UA users; we will continue to report any updates as they come, as well as at the end of the business day (5:00pm AKDT).

Thank you again for your time and patience with this issue!
Posted Jul 18, 2025 - 11:31 AKDT

Update

DocuSign has acknowledged this outage as system-wide for a number of their servers and are investigating. We will continue to make updates at 30minute intervals and relay updates posted by the vendor; you can view them in real-time here: https://status.docusign.com/incidents/fkyk4rkvdwsv

Thank you again for your time and patience!
Posted Jul 18, 2025 - 11:25 AKDT

Investigating

We have received reports that DocuSign is currently experiencing issues, and the eSignature application may be entirely unavailable at this time. The NTS Service Desk has reached out to the vendor and who is currently investigating, and we will be making updates at 30-minute intervals.

Thank you for your patience during the resolution of this issue!
Posted Jul 18, 2025 - 11:12 AKDT
This incident affected: Other IT Services.