UAA Citrix Application issues
Incident Report for OIT Services
Resolved
This issue has been resolved.
Posted Mar 28, 2019 - 14:43 AKDT
Investigating
Some Citrix applications have degraded performance and login issues while other applications are unaffected. We are currently trying to find the cause for the degradation.
Posted Mar 18, 2019 - 12:26 AKDT