Printer Logic Outage
Incident Report for OIT Services
Resolved
We have resolved the outage for printers.alaska.edu.
Posted Oct 21, 2021 - 13:11 AKDT
Investigating
We are working with the vendor to resolve an issue with printer logic. Currently users are unable to access printers.alaska.edu to add new printers, but printers previously added will continue to work.
Posted Oct 21, 2021 - 09:16 AKDT