TeamDynamix System Slowness
Incident Report for OIT Services
Resolved
TeamDynamix has marked this issue as resolved.
Posted Sep 23, 2022 - 09:10 AKDT
Investigating
TeamDynamix is currently experiencing a system outage. Technicians, students and staff using the ITSM ticketing client, project management application, or self service portal may experience slowness. We will be posting any updates from the vendor here.
Posted Sep 22, 2022 - 12:27 AKDT