Foxit Login
Incident Report for OIT Services
Postmortem

Background

Foxit is the supported program used to edit and read pdfs files.

Break Down of the Problem

On 14 November 2022 at approximately 16:00 the Service Desk started to receive numerous phone calls about Foxit not allowing users to login and wanting them to Activate or Purchase a License. The users were all authorized users that should have access but when Administrators could not log into the Foxit Admin console outage procedures started. Service Desk called UAA as the service owner technician is located there and was informed that the license for Foxit had expired and a new one was being implemented. Around approximately 17:00 the new license was implemented and some users were able to start using the program again. Service Desk did keep the outage in a monitoring state until 16 November 2022 because there were still users not able to readily access Foxit and most of those needed to have Foxit uninstalled and reinstalled before being able to login again. 

Target State / Goal 

Service should be available to customers 24/7 except during pre-defined maintenance windows.

Root Cause Analysis 

License had expired and a new one needed to be registered.

Develop Countermeasures 

Be aware of the new license expiring on 14 November 2023 and be ready to implement the new license or inform program users of the disruption in service.

Implementation of Countermeasures

14 November 2022 - new license 

Follow Up / Review

Update wiki article concerning Foxit to show expiration date of license and how to fix problems that may occur afterwards.

Posted Dec 14, 2022 - 10:25 AKST

Resolved
This incident has been resolved. If you are still having issues accessing the application please call the service desk for assistance with Foxit.
Posted Nov 16, 2022 - 10:30 AKST
Monitoring
The License for Foxit has been updated. All Users will now be able to sign into Foxit and activate the new license. You may need to log into Foxit again, to do so please follow these instructions https://alaska.edu/oit/services/software-downloads/licensed-software/foxit/foxit.php. Thank you for your patience during this time.
Posted Nov 14, 2022 - 16:27 AKST
Identified
The UA Foxit License has expired, we are currently working on renewing the license. We do not have time of resolution yet. Thank you for your patience.
Posted Nov 14, 2022 - 16:13 AKST