PAWS has resolved the issue with the alaska.edu and uaf.edu sites, and confirmed the fix to be stable.
Please report any continued issues with this service to your campus's IT helpdesk, and thank you again for your patience during the resolution of this issue!
Posted Sep 21, 2026 - 12:32 AKDT
Identified
Alaska.edu and uaf.edu websites are currently experiencing issues. The OIT Platforms, Apps & Web Services (PAWS) team is working with Security and they have identified the issue. The certificate should be updated within the hour and status updated as soon as it's resolved.
A current workaround is using a different browser than usual; Google Chrome has had high rates of success.
Thank you for your patience during the resolution of this issue!
Posted Sep 21, 2026 - 12:04 AKDT
Investigating
We have received reports that alaska.edu and uaf.edu websites are currently experiencing issues. The OIT Platforms, Apps & Web Services (PAWS) team is currently investigating, and we will be making updates at 3-hour intervals.
A current workaround is using a different browser than usual; Google Chrome has had high rates of success.
Thank you for your patience during the resolution of this issue!
Posted Sep 21, 2026 - 08:34 AKDT
This incident affected: Alaska.edu website (Alaska.edu Frontends) and UAF.edu website (UAF.edu Frontends).