Calls to Campus Partial Outage

Incident Report for NTS and OIT System

Resolved

We've had no further reports of issues calling the University, and the Fairbanks North Star Borough School District confirmed that their similar issues have been resolved. We are considering this outage resolved at this time; please call your campus IT service desk if you continue to have any issues contacting any UA campus by phone!

Thanks so much for your time.
Posted Aug 21, 2026 - 16:16 AKDT

Monitoring

Some AT&T mobile customers are currently unable to complete calls to campus phone numbers. This issue has been identified as originating with AT&T's network, not with our phone systems or services.

We are monitoring the situation and will provide an update once calls are confirmed to be working normally again.
Posted Aug 19, 2026 - 15:57 AKDT
This incident affected: Other IT Services.