The 'Foxit Clean Removal Tool' has been added to Software Center to allow non-admin users to uninstall the old version before installing Foxit 14. You may need to restart your computer in order for this to populate in your Software Center, and we do recommend restarting between the uninstallation and installation of any programs.
UAF NTS Service Desk Email: helpdesk@alaska.edu Phone: (907) 450-8300 Toll Free: 1-800-478-8226 Weekdays: 7:30 am - 7:30 pm Weekends: 10:00 am - 6:00 pm
UAS ITS Helpdesk Email: uas.helpdesk@alaska.edu Phone: 907-796-6400 Monday - Friday: 8:00 am - 5:00 pm Saturday - Sunday: Closed
----------
Thank you again for your time and patience as we continue to follow this issue; we will make further updates as new information becomes available, and at the end of the business day (5:00pm AKST).
Posted Nov 17, 2025 - 09:51 AKST
Update
The licensing on MacOS computers has been resolved-- simply re-activating it by logging in with SSO should be successful.
Please note that when updating the Windows version, users will first need to Uninstall the older version. If you are not an administrator on your device and are unable to do so, please contact your campus's IT service desk. Foxit 14 can be installed from the Software Center on UA devices, and you can download the installer from our Software Catalog for personal Windows devices: https://www.uaf.edu/nooktech/services/software-downloads/licensed-software/foxit/foxit.php
Thank you again for your time and patience as we follow the resolution of this issue!
UAF NTS Service Desk Email: helpdesk@alaska.edu Phone: (907) 450-8300 Toll Free: 1-800-478-8226 Weekdays: 7:30 am - 7:30 pm Weekends: 10:00 am - 6:00 pm
UAS ITS Helpdesk Email: uas.helpdesk@alaska.edu Phone: 907-796-6400 Monday - Friday: 8:00 am - 5:00 pm Saturday - Sunday: Closed
Posted Nov 17, 2025 - 09:05 AKST
Update
There appear to be further issues with the Software Center-installed version of Foxit on MacOS devices specifically, and users may not be able to reactivate even after updating. The NTS Technology Support Services team is aware and investigating!
We will update this status as new information becomes available, and at one-hour intervals. Thank you for your time as we do so!
Posted Nov 17, 2025 - 08:20 AKST
Update
Users may need to update their copy of Foxit in order to log in and reactivate it-- versions before 14.0 are outdated, and this can be performed by downloading the update from Software Center for users on UA computers, and from our software catalog for personal Windows devices (MacOS does not require an update): https://www.uaf.edu/nooktech/services/software-downloads/licensed-software/foxit/foxit.php
Thank you for your time and patience as we continue to follow this issue, we will make further updates as new information becomes available, and and at the end of the business day (5:00pm AKST).
Posted Nov 17, 2025 - 07:51 AKST
Monitoring
Foxit has erroneously notified some users of a license change and revocation of access during UAA's annual renewal cycle with the vendor. Users may need to sign into the application again to reactivate, but the product is available and there should be no disruption to the service itself.
UAA's engineering team is aware and determining the scope and effect, if any, of this issue. We will make an update as new information becomes available, and at the beginning of the business day (8:00AM AKST) Monday, 11/17.
Thanks so much for your time as we follow this issue!
Posted Nov 16, 2025 - 11:13 AKST
This incident affects: Software Licensing (Foxit License).