Banner Timing Out
Incident Report for OIT Services
Postmortem

Background

Banner is one of if not the most important system at the University of Alaska and is critical to business needs during and outside of normal business hours. Core university business functions related to finance, HR, and SIS management is facilitated through the product or integrations to the set of products. The previous weekend we had worked to move all production Banner systems to our vendor cloud hosted environment. The starting day was the first day after the system was declared live in the new environment.

Break Down of the Problem

On March 14, at approximately 10:20 am reports were sent into the EAS team related to object timeout and related database connectivity issues. When technicians investigated they noticed that all dependencies on the database were stuck for a period of time which had a rippling effect across all banner related jobs and integration. The vendor was immediately engaged and helped determine the underlying cause related to specific processes. We worked with the vendor to optimize some specific jobs immediately, and then when others were discovered carried out similar optimizations. 

Target State / Goal 

Banner should be available 24/7 with the exception of the pre-defined maintenance windows. 

Root Cause Analysis 

Technicians worked with the vendor to determine that some very large tables, when accessed through stock banner forms, were taking an excessive amount of time to complete read queries. This was due to statistical data not having been captured in the weeks leading up to the go-live event, which would have fed execution plans to optimize queries against these tables. Due to a lack of full system use during these times, this data wasn’t generated to be applied for the go-live event. 

Develop Countermeasures 

Routinely collect statistical data to update execution plans.

Implementation of Countermeasures

March 15, 2023  - Started capturing statistical data based on system real usage. 

Follow Up / Review

We have adopted a nightly running of the statistics in the new environment. This feeds into updating execution plans periodically.

Posted Apr 19, 2023 - 10:12 AKDT

Resolved
This incident has been resolved
Posted Mar 28, 2023 - 12:47 AKDT
Monitoring
We’ve been monitoring and improving Banner Cloud performance since the go-live and at this point the Banner database is performant. We will continue to monitor the service to ensure that it is running as expected. Please report any issues you see while interacting with Banner or UAOnline.
Posted Mar 23, 2023 - 16:25 AKDT
Identified
We are currently investigating user reports of issues in Banner. Thank you for your patience as we work towards a resolution.
Posted Mar 23, 2023 - 09:57 AKDT
Monitoring
We’ve been monitoring and improving Banner Cloud performance since the go-live and at this point the Banner database is performant. We will continue to monitor the service to ensure that it is running as expected. Please report any issues you see while interacting with Banner or UAOnline.
Posted Mar 23, 2023 - 09:43 AKDT
Update
We are currently getting reports that Banner is not allowing logins. We are looking into it and will report here as we learn more.
Posted Mar 20, 2023 - 09:37 AKDT
Investigating
We are currently tracking an issue with Banner where it keeps timing out. We are currently working with the vendor to resolve the issue. We thank you for you patience at this time.
Posted Mar 14, 2023 - 11:00 AKDT
This incident affected: Banner (Banner 9).