NTS Service Desk - Walk-In Support Unavailable

Incident Report for NTS and OIT System

Resolved

The Service Desk is back to operating at full capacity.
Posted Feb 25, 2026 - 10:20 AKST

Update

Due to Fairbanks weather conditions, the NTS Service Desk will have limited in-person support today, Feb 24th, between 8AM-5PM, with a break from 11:30AM - 12:30PM. The NTS Service Desk will remain open for phone, email and chat support during regularly scheduled hours, 7:30AM - 7:30PM.

https://www.uaf.edu/nooktech/get-help/
Posted Feb 24, 2026 - 10:40 AKST

Monitoring

Due to Fairbanks weather conditions, in-person support will be unavailable on Monday, Feb 23rd. The NTS Service Desk will remain available over phone, email and chat.

https://www.uaf.edu/nooktech/get-help/
Posted Feb 23, 2026 - 08:34 AKST
This incident affected: Other IT Services.