Ellucian, the vendor for Banner, has identified the issue and implemented a fix, which is being monitored for effectiveness and stability.
Thank you again for your patience during the resolution of this issue! You can expect another update at the end of the business day (5:00PM) or if new information becomes available.
Posted May 29, 2026 - 09:01 AKDT
Investigating
We have received reports that Banner Admin is currently experiencing issues at login.
A workaround has been identified for some users: attempt to load https://banner.alaska.edu/ in new incognito/private browser windows until the login screen successfully loads. The OIT Enterprise Applications Services (EAS) team is currently investigating, and we will be making updates at 1-hour intervals.
Thank you for your patience during the resolution of this issue!
Posted May 29, 2026 - 08:26 AKDT
This incident affects: Banner (Banner Admin Modules).